<!DOCTYPE html> <!--[if lt IE 7 ]><html class="ie ie6" lang="en"> <![endif]--> <!--[if IE 7 ]><html class="ie ie7" lang="en"> <![endif]--> <!--[if IE 8 ]><html class="ie ie8" lang="en"> <![endif]--> <!--[if (gte IE 9)|!(IE)]><!--><html lang="en-US"><!--<![endif]--><head><meta name="msvalidate.01" content="207E95D8EA6C8FF111607C6F3ABA60C6" /><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"> <!--[if lt IE 9]> <script src="https://glidemagazine.com/wp-content/themes/SmartPress/js/html5.js"></script> <![endif]--><link rel="icon" type="image/ico" href="https://glidemagazine.com/wp-content/themes/SmartPress/images/favicon.ico"><link rel="apple-touch-icon" href="https://glidemagazine.com/wp-content/themes/SmartPress/images/apple-touch-icon.png"><link rel="apple-touch-icon" sizes="72x72" href="https://glidemagazine.com/wp-content/themes/SmartPress/images/apple-touch-icon-72x72.png"> <script type="text/javascript">function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://glidemagazine.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://glidemagazine.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://glidemagazine.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")};var heateorSssWhatsappShareAPI = "web";</script> <link type="text/css" media="all" href="https://glidemagazine.com/wp-content/cache/autoptimize/css/autoptimize_1182964d3485a2c0c60b4bdeada6908a.css" rel="stylesheet" /><title>VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &quot;One and Only&quot; - Glide Magazine</title><meta name="description" content="Brooklyn-based singer-songwriter Ben Rice is one of those rare voices that references exceptional voices from years past, while earning nods as a"/><link rel="canonical" href="https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &quot;One and Only&quot; - Glide Magazine" /><meta property="og:description" content="Brooklyn-based singer-songwriter Ben Rice is one of those rare voices that references exceptional voices from years past, while earning nods as a" /><meta property="og:url" content="https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/" /><meta property="og:site_name" content="Glide Magazine" /><meta property="article:publisher" content="https://www.facebook.com/GlideMagazine" /><meta property="article:section" content="Media" /><meta property="article:published_time" content="2021-01-29T11:45:14-05:00" /><meta property="article:modified_time" content="2021-01-29T14:36:47-05:00" /><meta property="og:updated_time" content="2021-01-29T14:36:47-05:00" /><meta property="og:image" content="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-900x600.jpeg" /><meta property="og:image:secure_url" content="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-900x600.jpeg" /><meta property="og:image:width" content="900" /><meta property="og:image:height" content="600" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="Brooklyn-based singer-songwriter Ben Rice is one of those rare voices that references exceptional voices from years past, while earning nods as a" /><meta name="twitter:title" content="VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &quot;One and Only&quot; - Glide Magazine" /><meta name="twitter:site" content="@glidemag" /><meta name="twitter:image" content="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-scaled.jpeg" /><meta name="twitter:creator" content="@glidemag" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://glidemagazine.com/#organization","name":"Glide Magazine","url":"https://glidemagazine.com/","sameAs":["https://www.facebook.com/GlideMagazine","https://twitter.com/glidemag"],"logo":{"@type":"ImageObject","@id":"https://glidemagazine.com/#logo","url":"https://glidemagazine.com/wp-content/uploads/2017/08/glide_logo_300-150x150.png","caption":"Glide Magazine"},"image":{"@id":"https://glidemagazine.com/#logo"}},{"@type":"WebSite","@id":"https://glidemagazine.com/#website","url":"https://glidemagazine.com/","name":"Glide Magazine","publisher":{"@id":"https://glidemagazine.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://glidemagazine.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#webpage","url":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/","inLanguage":"en-US","name":"VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &quot;One and Only&quot; - Glide Magazine","isPartOf":{"@id":"https://glidemagazine.com/#website"},"image":{"@type":"ImageObject","@id":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#primaryimage","url":"https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-scaled.jpeg","width":2560,"height":1708},"primaryImageOfPage":{"@id":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#primaryimage"},"datePublished":"2021-01-29T11:45:14-05:00","dateModified":"2021-01-29T14:36:47-05:00","description":"Brooklyn-based singer-songwriter Ben Rice is one of those rare voices that references exceptional voices from years past, while earning nods as a"},{"@type":"Article","@id":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#article","isPartOf":{"@id":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#webpage"},"author":{"@id":"https://glidemagazine.com/author/glideadmin/#author","name":"Glide"},"publisher":{"@id":"https://glidemagazine.com/#organization"},"headline":"VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &#8220;One and Only&#8221;","datePublished":"2021-01-29T11:45:14-05:00","dateModified":"2021-01-29T14:36:47-05:00","commentCount":0,"mainEntityOfPage":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#webpage","image":{"@id":"https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#primaryimage"},"articleSection":"Audio,Media"},{"@type":"Person","@id":"https://glidemagazine.com/author/glideadmin/#author","name":"Glide","image":{"@type":"ImageObject","@id":"https://glidemagazine.com/#personlogo","url":"https://secure.gravatar.com/avatar/b62389276a764499b4f16ac77e638ab2?s=96&d=mm&r=g","caption":"Glide"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//secure.gravatar.com' /> <script type='text/javascript' src='https://glidemagazine.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var mailermailer_params = {"mm_url":"https:\/\/glidemagazine.com\/","mm_pub_key":""};</script> <script type='text/javascript'>var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/glidemagazine.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"253000","token":"65053fd2bc","debug":""};</script> <link rel='https://api.w.org/' href='https://glidemagazine.com/wp-json/' /><link rel='shortlink' href='https://wp.me/p9XYG5-13OE' /><link rel="alternate" type="application/json+oembed" href="https://glidemagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F" /><link rel="alternate" type="text/xml+oembed" href="https://glidemagazine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F&#038;format=xml" />  <script type="text/javascript">jQuery(function(){

		jQuery.fn.getTitle = function() { // Copy the title of every IMG tag and add it to its parent A so that fancybox can show titles
			var arr = jQuery("a[data-fancybox]");
									jQuery.each(arr, function() {
										var title = jQuery(this).children("img").attr("title");
										 var caption = jQuery(this).next("figcaption").html();
                                        if(caption && title){jQuery(this).attr("title",title+" " + caption)}else if(title){ jQuery(this).attr("title",title);}else if(caption){jQuery(this).attr("title",caption);}
									});			}

		// Supported file extensions

                var thumbnails = jQuery("a:has(img)").not(".nolightbox").not('.envira-gallery-link').not('.ngg-simplelightbox').filter(function () {
            return /\.(jpe?g|png|gif|mp4|webp|bmp|pdf)(\?[^/]*)*$/i.test(jQuery(this).attr('href'))
        });
        

		// Add data-type iframe for links that are not images or videos.
        var iframeLinks = jQuery('.fancyboxforwp').filter( function() { return ! /\.(jpe?g|png|gif|mp4|webp|bmp|pdf)(\?[^/]*)*$/i.test(jQuery(this).attr('href')) }).filter( function() { return ! /vimeo|youtube/i.test(jQuery(this).attr('href')) });
        iframeLinks.attr({ "data-type" : "iframe" }).getTitle();

				// Gallery All
		thumbnails.addClass("fancyboxforwp").attr("data-fancybox","gallery").getTitle();
        iframeLinks.attr({ "data-fancybox":"gallery" }).getTitle();

		// Gallery type NONE
		


		// Call fancybox and apply it on any link with a rel atribute that starts with "fancybox", with the options set on the admin panel
		jQuery("a.fancyboxforwp").fancyboxforwp({
			loop: false,
			smallBtn: true,
			zoomOpacity: "auto",
			animationEffect: "fade",
			animationDuration: 500,
			transitionEffect: "fade",
			transitionDuration : "300",
			overlayShow: true,
			overlayOpacity: "0.3",
			titleShow: true,
			titlePosition: "inside",
			keyboard: true,
			showCloseButton: true,
			arrows: true,
			clickContent: false,
            clickSlide: "close",
			wheel: false,
			toolbar: true,
			preventCaptionOverlap: true,
			onInit: function() { },			onDeactivate: function() { },			beforeClose: function() { },			afterShow: function() { },			afterClose: function() { },			caption : function( instance, item ) {var testing = jQuery(this).context.title;var caption = jQuery(this).data('caption') || '';if ( item.type === 'image' && testing.length ) {caption = (caption.length ? caption + '<br />' : '') + '<p class="caption-title">'+testing+'</p>' ;}return caption;},
			afterLoad : function( instance, current ) {current.$content.append('<div class=\"fancybox-custom-caption\" style=\" position: absolute;left:0;right:0;color:#000;padding-top:10px;bottom:-50px;margin:0 auto;text-align:center; \">' + current.opts.caption + '</div>');},
					});
		
	})</script>  <script data-cfasync='false'  src='//monu.delivery/site/3/4/9cdd49-aeab-44da-ab0c-9fef9450d375.js' type='text/javascript'></script> <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//glidemagazine.com/?wordfence_lh=1&hid=1E874C1D1CE0D8655C0BD5146450C145');</script> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-3103882-1"></script> <script>window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-3103882-1');</script> <link rel='dns-prefetch' href='//v0.wordpress.com'/> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="icon" href="https://glidemagazine.com/wp-content/uploads/2017/03/glide_logo_300-150x150-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://glidemagazine.com/wp-content/uploads/2017/03/glide_logo_300-150x150-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://glidemagazine.com/wp-content/uploads/2017/03/glide_logo_300-150x150-1-180x180.png" /><meta name="msapplication-TileImage" content="https://glidemagazine.com/wp-content/uploads/2017/03/glide_logo_300-150x150-1-270x270.png" /> <script type="text/javascript">setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//dnn506yrbagrg.cloudfront.net/pages/scripts/0014/4209.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);</script> </head><body class="post-template-default single single-post postid-253000 single-format-standard"> <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MH9H6J"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MH9H6J');</script> <div class="container"><div class="sixteen columns row"><div id="header"><div id="logo"> <a href="https://glidemagazine.com"><imgarea><img src="https://glide-media-cloud.s3-accelerate.amazonaws.com/2017/08/glide_logo_300-150x150.png" alt="Glide Magazine" /></imgarea></a></div><div class="alignright"></div><div style="text-align: center;" id="advert"><div id="mmt-fe8c7728-f20a-4e33-adc2-99ce7ca75450"></div> <script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["fe8c7728-f20a-4e33-adc2-99ce7ca75450"]); })</script> </div><div class="clear"></div></div><div id="nav"> <button id="hamburger_button">MENU</button> <script>$(function(){
					$('#hamburger_button').click(function(e){
						$('#nav').toggleClass('show');
					})
				});</script> <div class="menu-main-menu-container"><ul id="mainmenu" class="sf-menu"><li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://glidemagazine.com/category/news/">News</a></li><li id="menu-item-65" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65"><a href="https://glidemagazine.com/category/features/">Interviews</a></li><li id="menu-item-148296" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148296"><a href="https://glidemagazine.com/category/premieres/">PREMIERES</a></li><li id="menu-item-61" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-61"><a href="https://glidemagazine.com/category/reviews/">Reviews</a><ul class="sub-menu"><li id="menu-item-64" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64"><a href="https://glidemagazine.com/category/reviews/albumreviews/">Album Reviews</a></li><li id="menu-item-62" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62"><a href="https://glidemagazine.com/category/reviews/concertreviews/">Concert Reviews</a></li><li id="menu-item-115148" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115148"><a href="https://glidemagazine.com/category/reviews/television-film/">Television &#038; Film</a></li><li id="menu-item-63" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="https://glidemagazine.com/category/reviews/dvdreviews/">DVD Reviews</a></li><li id="menu-item-79" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79"><a href="https://glidemagazine.com/category/reviews/otherreviews/">Other Reviews</a></li></ul></li><li id="menu-item-158213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158213"><a href="https://glidemagazine.com/category/film-tv/">Film &#038; TV</a><ul class="sub-menu"><li id="menu-item-158206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158206"><a href="https://glidemagazine.com/category/film-tv/filmreviews/">Film Reviews</a></li><li id="menu-item-158208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158208"><a href="https://glidemagazine.com/category/film-tv/tvreviews/">TV Reviews</a></li><li id="menu-item-158207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158207"><a href="https://glidemagazine.com/category/film-tv/trailers/">Trailers</a></li><li id="menu-item-158350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158350"><a href="https://glidemagazine.com/category/film-tv/commentarytracks/">Commentary Tracks</a></li></ul></li><li id="menu-item-87" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-87"><a href="https://glidemagazine.com/category/media/">Media</a><ul class="sub-menu"><li id="menu-item-118" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-118"><a href="https://glidemagazine.com/video/">Video</a></li><li id="menu-item-88" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88"><a href="https://glidemagazine.com/category/media/audio/">Audio</a></li><li id="menu-item-124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-124"><a href="https://glidemagazine.com/category/media/photos/">Photos</a></li><li id="menu-item-245801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-245801"><a href="https://glidemagazine.com/category/media/medium-fidelity-podcast/">Medium Fidelity Podcast</a></li></ul></li><li id="menu-item-80" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-80"><a href="https://glidemagazine.com/category/columns/">Columns</a><ul class="sub-menu"><li id="menu-item-25492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25492"><a href="https://glidemagazine.com/category/columns/my-roots/">My Roots</a></li><li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://glidemagazine.com/category/columns/bsides/">B-Sides</a></li><li id="menu-item-82" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82"><a href="https://glidemagazine.com/category/columns/hotspot/">Hot Spot</a></li><li id="menu-item-36001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36001"><a href="https://glidemagazine.com/category/columns/vinyl-lives/">Vinyl Lives</a></li><li id="menu-item-172020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-172020"><a href="https://glidemagazine.com/category/columns/soundssounds/">Suds &#038; Sounds</a></li><li id="menu-item-86" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-86"><a href="https://glidemagazine.com/category/columns/take5/">Take 5</a></li><li id="menu-item-172021" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-172021"><a href="https://glidemagazine.com/category/columns/one-track-mind/">One Track Mind</a></li><li id="menu-item-36000" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36000"><a href="https://glidemagazine.com/category/columns/vintage-stash/">Vintage Stash</a></li><li id="menu-item-145063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-145063"><a href="https://glidemagazine.com/category/columns/hiddentrack/">Hidden Track</a></li></ul></li><li id="menu-item-115307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115307"><a href="https://glidemagazine.com/category/giveaways/">Giveaways</a></li><li id="menu-item-181" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-181"><a href="https://glidemagazine.com/about/">About</a><ul class="sub-menu"><li id="menu-item-342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-342"><a href="https://glidemagazine.com/staff/">Staff</a></li><li id="menu-item-324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-324"><a href="https://glidemagazine.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-323"><a href="https://glidemagazine.com/advertise-with-us/">Advertise With Us</a></li><li id="menu-item-354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-354"><a href="https://glidemagazine.com/contact-us/">Contact Us</a></li></ul></li></ul></div><div class="alignright"><div id="social_network"> <a target="_blank" href="https://www.facebook.com/GlideMagazine/" class="facebook" target="_blank"></a> <a target="_blank" href="http://twitter.com/glidemag" class="twitter" target="_blank"></a> <a href="http://feeds.feedburner.com/GlideMagazine" class="feed" target="_blank"></a></div><div id="branding"><form method="get" id="searchform" action="https://glidemagazine.com"> <input id="s" class="field" type="text" value="Search" onFocus="if(this.value==this.defaultValue)this.value='';" onBlur="if(this.value=='')this.value=this.defaultValue;" name="s"> <input id="searchsubmit" class="submit" type="submit" value="Search" name="submit"></form></div></div><div class="clear"></div></div></div><div class="clear"></div><div class="two-thirds column"><div class="box_wrapper"><h1>VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &#8220;One and Only&#8221;</h1><div class="post_content"><div class="post single"><div class="post_meta"><span class="post_date">January 29, 2021</span> <span class="post_by">by <a href="https://glidemagazine.com/author/glideadmin/" title="Posts by Glide" rel="author">Glide</a></span> <span class="post_cat">in <a href="https://glidemagazine.com/category/media/audio/" rel="category tag">Audio</a>, <a href="https://glidemagazine.com/category/media/" rel="category tag">Media</a></span> <a href="https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#respond" class="post_comment" >No Comments</a></div><div class="post_entry"><div class="row"><a href="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-scaled.jpeg" title="VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &#8220;One and Only&#8221;" rel="prettyPhoto"><img width="578" height="289" src="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-578x289.jpeg" class="scale-with-grid wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-578x289.jpeg 578w, https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-270x135.jpeg 270w" data-lazy-sizes="(max-width: 578px) 100vw, 578px" data-lazy-src="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2021/01/29092224/benrice-578x289.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div> <script>jQuery(document).ready(function($){

					$(".post_content a[rel^='prettyPhoto']").prettyPhoto();

				});</script> <div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/'><div class='heateor_sss_sharing_title' style="font-weight:bold" ></div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?text=VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22&#038;url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Pinterest" Title="Pinterest" class="heateorSssSharing heateorSssPinterestBackground" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssPinterestSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Reddit" Title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F&#038;title=VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Email" Title="Email" class="heateorSssSharing heateorSssEmailBackground"  onclick="window.location.href = 'mailto:?subject=' + decodeURIComponent('VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22' ).replace('&#038;', '%26') + '&#038;body=' + decodeURIComponent('https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F' )"><ss style="display:block" class="heateorSssSharingSvg heateorSssEmailSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Mix" Title="Mix" class="heateorSssSharing heateorSssMixBackground" onclick='heateorSssPopup("https://mix.com/mixit?url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssMixSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" title="More" alt="More" class="heateorSssSharing heateorSssMoreBackground" onclick="heateorSssMoreSharingPopup(this, 'https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/', 'VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22', '' )" ><ss style="display:block" class="heateorSssSharingSvg heateorSssMoreSvg"></ss></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div><p></p><p class="p5">Brooklyn-based singer-songwriter <b>Ben Rice</b> is one of those rare voices that references exceptional voices from years past, while earning nods as a must-hear singer-songwriter in today&#8217;s world of Isbell, Stapleton, and Carlile.  Rice&#8217;s forthcoming album <b><i>Future Pretend</i></b> is due February 19, 2021 and <strong><em>Glide</em> is premiering the video for the radio-ready &#8220;One and Only.&#8221;</strong> Rice strums up a touch of the Tom Petty jukebox with his shiny draw and top-notch musicianship surrounding him &#8211; you could have sworn this track is a lost B-side from<em> Damn The Torpedoes</em>. Check out this rocker below&#8230;</p><p>One and Only” was a turning point for me &#8211; both in committing to making this record, “Future Pretend”, and recommitting myself to living in New York City,&#8221; describes Rice. &#8220;At the time I wrote it I was pretty burned out on living in the city and wasn’t totally convinced I even wanted to make an album, but when I wrote this song it felt really invigorating to me and made me feel like I needed to be in the city making music.&#8221;</p><p><iframe src="https://www.youtube.com/embed/eti9oB245ec" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p><p>&nbsp;</p><p class="p5">Having come of age in early 2000s New York City obsessed with baseball and rock n’ roll, Rice was just in time to savor an iconic run of Yankees championships, and relish the Gotham rock renaissance epitomized by The Strokes. Twenty years later, legendary music venues have been replaced by banks and disposable retail shops and brownstone buildings have been leveled to make room for luxury high rises. Yet, although the spaces change, the spirit lives on with Rice who embraces big city Americana on his debut solo album, brimming with ruminations on culture, society, and personal evolution.</p><p class="p5">“Over the past few years, I’ve seen my city and my world change so much. I’ve dealt with the loss of friends and family, gotten engaged and gotten to be a part of some amazing projects creatively. I knew these were all such significant life moments that it felt imperative that I was truly present,” Rice says. “We spend so much time mired in our memories, or fixated on a pretend version of a future reality, that we can miss out on experiencing our lives as they are happening. For me, the main concept of the record is the pursuit of being present, framed by the experiences that have taken me to this place.”</p><p class="p5">Rice spent his early 20s on the road with various indie-rock bands, and later laid down roots as a producer and session musician in Brooklyn, NY at his studio, <b>Degraw Sound</b>, where he recorded <i>Future Pretend</i>. He went into 2020 riding high, playing guitar on <b>a Jonas Brothers</b> chart-topping track; co-writing in LA with powerhouse songwriters; and delving into production on a number of exciting projects. But by the spring of 2020, when New York shut down for the pandemic, Rice was on the brink of a shutdown himself.</p><p class="p5">“After grinding non-stop for as long as I could remember, I was forced to take a few weeks off, like an extended snow day. Having that time made me realize how burned out I really was and gave me a moment to reset. I had spent the past decade immersed in other people’s music and had shut off a certain creative lobe in my brain, but with this pause, lyrics and melodies for my own songs started coming to me again. Then I realized, ‘I have this studio that is sitting there vacant…’,” Rice recalls.</p><p class="p5">Rice wrote, produced, engineered and mixed the nine tracks on the album at Degraw Sound. He is a seasoned musician; outside of his solo career Rice has worked as a producer, studio guitarist, and bandleader. Select career highlights include producing for <b>Norah Jones</b> and <b>Valerie June</b>; studio guitar work for <b>Fletcher</b> and on a <b>Billboard #1 hit for the Jonas Brothers</b>; playing in indie rock bands signed to WMG; and sharing the stage with artists like <b>Arctic Monkeys</b> and <b>Brendan Benson</b>.</p><p class="p5">A solo album was a surprise gift from the pandemic, enabling Rice to make the most of a forced life pause. He says: “It had been 8 years since I put out a full-length album, and this record woke something up in me. It made me present, and it taught me if you want to do something, you have to be all in.”</p><p></p><div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/'><div class='heateor_sss_sharing_title' style="font-weight:bold" ></div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?text=VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22&#038;url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Pinterest" Title="Pinterest" class="heateorSssSharing heateorSssPinterestBackground" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssPinterestSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Reddit" Title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F&#038;title=VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Email" Title="Email" class="heateorSssSharing heateorSssEmailBackground"  onclick="window.location.href = 'mailto:?subject=' + decodeURIComponent('VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22' ).replace('&#038;', '%26') + '&#038;body=' + decodeURIComponent('https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F' )"><ss style="display:block" class="heateorSssSharingSvg heateorSssEmailSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Mix" Title="Mix" class="heateorSssSharing heateorSssMixBackground" onclick='heateorSssPopup("https://mix.com/mixit?url=https%3A%2F%2Fglidemagazine.com%2F253000%2Fvideo-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssMixSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" title="More" alt="More" class="heateorSssSharing heateorSssMoreBackground" onclick="heateorSssMoreSharingPopup(this, 'https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/', 'VIDEO%20PREMIERE%3A%20Ben%20Rice%20Strums%20Up%20Shades%20of%20Petty%20On%20Power%20Pop%20Gem%20%22One%20and%20Only%22', '' )" ><ss style="display:block" class="heateorSssSharingSvg heateorSssMoreSvg"></ss></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div></div></div><div class="post_author"><div class="thumb alignleft"><img alt src="https://secure.gravatar.com/avatar/b62389276a764499b4f16ac77e638ab2?s=60&#038;d=mm&#038;r=g" class="avatar avatar-60 photo jetpack-lazy-image" height="60" width="60" data-lazy-srcset="https://secure.gravatar.com/avatar/b62389276a764499b4f16ac77e638ab2?s=120&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/b62389276a764499b4f16ac77e638ab2?s=60&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/b62389276a764499b4f16ac77e638ab2?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/b62389276a764499b4f16ac77e638ab2?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></noscript></div><h4>About the author: <a href="https://glidemagazine.com/author/glideadmin/" title="Posts by Glide" rel="author">Glide</a></h4><p></p><div class="clear"></div></div><div class="related_post"><h3 class="widget_title">Related Posts</h3><ul class="recent_posts"><li> <a class="thumb alignleft" href="https://glidemagazine.com/236580/song-premiere-listen-to-mister-rogers-sing-what-would-you-like-to-do-today-off-upcoming-omnivore-reissue/" title="SONG PREMIERE: Listen to Mister Rogers Sing &#8220;What Would You Like To Do Today&#8221; Off Upcoming Omnivore Reissue"><img src="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2019/11/02053919/unnamed-4-50x50.jpg" width="50" height="50" alt="SONG PREMIERE: Listen to Mister Rogers Sing &#8220;What Would You Like To Do Today&#8221; Off Upcoming Omnivore Reissue"></a><p><a href="https://glidemagazine.com/236580/song-premiere-listen-to-mister-rogers-sing-what-would-you-like-to-do-today-off-upcoming-omnivore-reissue/" title="SONG PREMIERE: Listen to Mister Rogers Sing &#8220;What Would You Like To Do Today&#8221; Off Upcoming Omnivore Reissue" class="title">SONG PREMIERE: Listen to Mister Rogers Sing &#8220;What Would You ...</a> <span class="datetime">November 14, 2019 9:30 am</span></p><div class="clear"></div></li><li> <a class="thumb alignleft" href="https://glidemagazine.com/228796/album-premiere-interview-karen-jonas-takes-a-wide-ranging-approach-to-country-on-lucky-revisted/" title="ALBUM PREMIERE/INTERVIEW: Karen Jonas Takes a Wide-Ranging Approach to Country on &#8216;Lucky, Revisted&#8217;"><img src="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2019/07/02160536/KarenJonas-6_PhotoCredit-AmberReneePhotography-50x50.jpg" width="50" height="50" alt="ALBUM PREMIERE/INTERVIEW: Karen Jonas Takes a Wide-Ranging Approach to Country on &#8216;Lucky, Revisted&#8217;"></a><p><a href="https://glidemagazine.com/228796/album-premiere-interview-karen-jonas-takes-a-wide-ranging-approach-to-country-on-lucky-revisted/" title="ALBUM PREMIERE/INTERVIEW: Karen Jonas Takes a Wide-Ranging Approach to Country on &#8216;Lucky, Revisted&#8217;" class="title">ALBUM PREMIERE/INTERVIEW: Karen Jonas Takes a Wide-Ranging Approach to Country ...</a> <span class="datetime">July 17, 2019 9:32 am</span></p><div class="clear"></div></li><li> <a class="thumb alignleft" href="https://glidemagazine.com/43255/manchester-orchestra-debuts-top-notch-from-new-album-cope/" title="Manchester Orchestra Debuts &#8220;Top Notch&#8221; From New Album Cope"><img src="https://glidemagazine.com/wp-content/uploads/2014/01/manchesterorch-50x50.jpg" width="50" height="50" alt="Manchester Orchestra Debuts &#8220;Top Notch&#8221; From New Album Cope"></a><p><a href="https://glidemagazine.com/43255/manchester-orchestra-debuts-top-notch-from-new-album-cope/" title="Manchester Orchestra Debuts &#8220;Top Notch&#8221; From New Album Cope" class="title">Manchester Orchestra Debuts &#8220;Top Notch&#8221; From New Album Cope</a> <span class="datetime">January 22, 2014 10:45 am</span></p><div class="clear"></div></li><li> <a class="thumb alignleft" href="https://glidemagazine.com/189892/song-premiere-john-prine-sideman-jason-wilber-makes-resounding-folk-rock-statement-reaction-time/" title="SONG PREMIERE: John Prine Sideman Jason Wilber Makes Resounding Folk Rock Statement With &#8220;Reaction Time&#8221;"><img src="https://glidemagazine.com/wp-content/uploads/2017/07/wilberindex-50x50.jpg" width="50" height="50" alt="SONG PREMIERE: John Prine Sideman Jason Wilber Makes Resounding Folk Rock Statement With &#8220;Reaction Time&#8221;"></a><p><a href="https://glidemagazine.com/189892/song-premiere-john-prine-sideman-jason-wilber-makes-resounding-folk-rock-statement-reaction-time/" title="SONG PREMIERE: John Prine Sideman Jason Wilber Makes Resounding Folk Rock Statement With &#8220;Reaction Time&#8221;" class="title">SONG PREMIERE: John Prine Sideman Jason Wilber Makes Resounding Folk ...</a> <span class="datetime">July 28, 2017 4:52 am</span></p><div class="clear"></div></li><li> <a class="thumb alignleft" href="https://glidemagazine.com/249861/listen-aussie-via-cali-songwriter-mimi-gilbert-enlightens-on-taught-to-build-walls/" title="LISTEN: Aussie via Cali Songwriter Mimi Gilbert Enlightens On &#8220;Taught to Build Walls&#8221;"><img src="https://glide-assets-media.s3.amazonaws.com/wp-content/uploads/2020/10/25154356/mimi-50x50.jpg" width="50" height="50" alt="LISTEN: Aussie via Cali Songwriter Mimi Gilbert Enlightens On &#8220;Taught to Build Walls&#8221;"></a><p><a href="https://glidemagazine.com/249861/listen-aussie-via-cali-songwriter-mimi-gilbert-enlightens-on-taught-to-build-walls/" title="LISTEN: Aussie via Cali Songwriter Mimi Gilbert Enlightens On &#8220;Taught to Build Walls&#8221;" class="title">LISTEN: Aussie via Cali Songwriter Mimi Gilbert Enlightens On &#8220;Taught ...</a> <span class="datetime">October 25, 2020 4:41 pm</span></p><div class="clear"></div></li></ul><div class="clear"></div></div><div id="respond"><h3>Leave A Response</h3><ul><form action="https://glidemagazine.com/wp-comments-post.php" method="post" id="commentform"><li> <label for="author">Name <span class="required">*</span></label> <input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' class="txt" /></li><li> <label for="email"> Email Address <span class="req"><span class="required">*</span></span></label> <input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' class="txt"  /></li><li> <label for="url">Website</label> <input type="text" name="url" id="url" value="" size="22" tabindex="3" class="txt" /></li><li> <label for="comment">Your Comments <span class="required">*</span></label><textarea name="comment" id="comment" rows="15" cols="50" tabindex="4"></textarea><a rel="nofollow" id="cancel-comment-reply-link" href="/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/#respond" style="display:none;">Click here to cancel reply.</a></li><li class="last"> <input name="submit" type="submit" id="add_comment" tabindex="5" value="Add Comment" class="button" /></li> <input type='hidden' name='comment_post_ID' value='253000' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /><p id="nsu-checkbox"> <label for="nsu-checkbox-input" id="nsu-checkbox-label"> <input value="1" id="nsu-checkbox-input" type="checkbox" name="newsletter-sign-up-do"  checked='checked' /> </label></p></form></ul></div><div class="clear"></div></div></div></div><div id="sidebar" class="one-third column"><center><div id="mmt-1eed6b76-2e60-48dd-8499-a1e2f37cf0ce"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["1eed6b76-2e60-48dd-8499-a1e2f37cf0ce"]); })</script> </center> <br><div id="mailermailer_widget-6" class="widget box_wrapper widget_mailermailer_widget"><h3>Keep Up To Date With Glide</h3><div id="mm_signup_form_content"><form method= "post" action="#mm_signup_form" id="mm_signup_form" style="border-width: 1px;border-style: solid;border-color: #75CCD0;color: #ffffff;background-color: #75CCD0;"> <input type= "hidden" name= "mm_request" value= "mm_form_submit" /> <input type= "hidden" id="mm_is_javascript" name="mm_is_javascript" value= "no"/><div id="mm_msg"></div> <label>Email Address <em>*</em></label><div><input type="text" name="mm_user_email" id="mm_user_email" maxlength="100"/></div><div><em>*</em> denotes a required field</div> <input type="submit" name="mm_signup_submit" id="mm_signup_submit" value="Subscribe" class="button" /></form></div></div><div id="recent-posts-4" class="widget box_wrapper widget_recent_entries"><h3>New To Glide</h3><ul><li> <a href="https://glidemagazine.com/252996/the-little-things-review/">&#8216;The Little Things&#8217; Might Have Been Great in 1993 (FILM REVIEW)</a></li><li> <a href="https://glidemagazine.com/252991/saint-maud-film-review/">&#8216;Saint Maud&#8217; Utilizes Its Eerie Atmosphere and Relentless Tension to Horrifying Effect (FILM REVIEW)</a></li><li> <a href="https://glidemagazine.com/252979/video-premiere-rosk-channels-dark-and-danceable-80s-synth-pop-swagger-on-art-collective/">VIDEO PREMIERE: Rosk Channels Dark and Danceable 80s Synth Pop Swagger on &#8220;Art Collective&#8221;</a></li><li> <a href="https://glidemagazine.com/252957/lucero-continue-to-evolve-with-80s-rock-and-roll-sounds-on-when-you-found-me-album-review/">Lucero Continue to Evolve with 80s Rock and Roll Sounds on &#8216;When You Found Me&#8217; (ALBUM REVIEW)</a></li><li> <a href="https://glidemagazine.com/253000/video-premiere-ben-rice-strums-up-shades-of-petty-on-power-pop-gem-one-and-only/" aria-current="page">VIDEO PREMIERE: Ben Rice Strums Up Shades of Petty On Power Pop Gem &#8220;One and Only&#8221;</a></li><li> <a href="https://glidemagazine.com/252955/ghalia-volt-immerses-herself-in-the-blues-with-one-woman-band-album-review/">Ghalia Volt Immerses Herself in the Blues with &#8216;One Woman Band&#8217; (ALBUM REVIEW)</a></li></ul></div><div id="custom_html-4" class="widget_text widget box_wrapper widget_custom_html"><div class="textwidget custom-html-widget"><center><div id="mmt-bb566b3b-99ad-41b4-9be5-0c517452ab78"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["bb566b3b-99ad-41b4-9be5-0c517452ab78"]); })</script> </center></div></div><div id="text-6" class="widget box_wrapper widget_text"><div class="textwidget"><a class="twitter-timeline" data-width="300" data-height="700" href="https://twitter.com/glidemag?ref_src=twsrc%5Etfw">Tweets by glidemag</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div><div id="archives-3" class="widget box_wrapper widget_archive"><h3>Archives</h3> <label class="screen-reader-text" for="archives-dropdown-3">Archives</label> <select id="archives-dropdown-3" name="archive-dropdown"><option value="">Select Month</option><option value='https://glidemagazine.com/date/2021/01/'> January 2021 &nbsp;(184)</option><option value='https://glidemagazine.com/date/2020/12/'> December 2020 &nbsp;(181)</option><option value='https://glidemagazine.com/date/2020/11/'> November 2020 &nbsp;(178)</option><option value='https://glidemagazine.com/date/2020/10/'> October 2020 &nbsp;(232)</option><option value='https://glidemagazine.com/date/2020/09/'> September 2020 &nbsp;(210)</option><option value='https://glidemagazine.com/date/2020/08/'> August 2020 &nbsp;(186)</option><option value='https://glidemagazine.com/date/2020/07/'> July 2020 &nbsp;(193)</option><option value='https://glidemagazine.com/date/2020/06/'> June 2020 &nbsp;(198)</option><option value='https://glidemagazine.com/date/2020/05/'> May 2020 &nbsp;(192)</option><option value='https://glidemagazine.com/date/2020/04/'> April 2020 &nbsp;(218)</option><option value='https://glidemagazine.com/date/2020/03/'> March 2020 &nbsp;(202)</option><option value='https://glidemagazine.com/date/2020/02/'> February 2020 &nbsp;(205)</option><option value='https://glidemagazine.com/date/2020/01/'> January 2020 &nbsp;(170)</option><option value='https://glidemagazine.com/date/2019/12/'> December 2019 &nbsp;(93)</option><option value='https://glidemagazine.com/date/2019/11/'> November 2019 &nbsp;(145)</option><option value='https://glidemagazine.com/date/2019/10/'> October 2019 &nbsp;(187)</option><option value='https://glidemagazine.com/date/2019/09/'> September 2019 &nbsp;(192)</option><option value='https://glidemagazine.com/date/2019/08/'> August 2019 &nbsp;(173)</option><option value='https://glidemagazine.com/date/2019/07/'> July 2019 &nbsp;(150)</option><option value='https://glidemagazine.com/date/2019/06/'> June 2019 &nbsp;(171)</option><option value='https://glidemagazine.com/date/2019/05/'> May 2019 &nbsp;(195)</option><option value='https://glidemagazine.com/date/2019/04/'> April 2019 &nbsp;(182)</option><option value='https://glidemagazine.com/date/2019/03/'> March 2019 &nbsp;(189)</option><option value='https://glidemagazine.com/date/2019/02/'> February 2019 &nbsp;(172)</option><option value='https://glidemagazine.com/date/2019/01/'> January 2019 &nbsp;(173)</option><option value='https://glidemagazine.com/date/2018/12/'> December 2018 &nbsp;(96)</option><option value='https://glidemagazine.com/date/2018/11/'> November 2018 &nbsp;(147)</option><option value='https://glidemagazine.com/date/2018/10/'> October 2018 &nbsp;(188)</option><option value='https://glidemagazine.com/date/2018/09/'> September 2018 &nbsp;(176)</option><option value='https://glidemagazine.com/date/2018/08/'> August 2018 &nbsp;(154)</option><option value='https://glidemagazine.com/date/2018/07/'> July 2018 &nbsp;(151)</option><option value='https://glidemagazine.com/date/2018/06/'> June 2018 &nbsp;(148)</option><option value='https://glidemagazine.com/date/2018/05/'> May 2018 &nbsp;(187)</option><option value='https://glidemagazine.com/date/2018/04/'> April 2018 &nbsp;(163)</option><option value='https://glidemagazine.com/date/2018/03/'> March 2018 &nbsp;(212)</option><option value='https://glidemagazine.com/date/2018/02/'> February 2018 &nbsp;(164)</option><option value='https://glidemagazine.com/date/2018/01/'> January 2018 &nbsp;(154)</option><option value='https://glidemagazine.com/date/2017/12/'> December 2017 &nbsp;(93)</option><option value='https://glidemagazine.com/date/2017/11/'> November 2017 &nbsp;(154)</option><option value='https://glidemagazine.com/date/2017/10/'> October 2017 &nbsp;(161)</option><option value='https://glidemagazine.com/date/2017/09/'> September 2017 &nbsp;(167)</option><option value='https://glidemagazine.com/date/2017/08/'> August 2017 &nbsp;(165)</option><option value='https://glidemagazine.com/date/2017/07/'> July 2017 &nbsp;(145)</option><option value='https://glidemagazine.com/date/2017/06/'> June 2017 &nbsp;(194)</option><option value='https://glidemagazine.com/date/2017/05/'> May 2017 &nbsp;(200)</option><option value='https://glidemagazine.com/date/2017/04/'> April 2017 &nbsp;(162)</option><option value='https://glidemagazine.com/date/2017/03/'> March 2017 &nbsp;(199)</option><option value='https://glidemagazine.com/date/2017/02/'> February 2017 &nbsp;(169)</option><option value='https://glidemagazine.com/date/2017/01/'> January 2017 &nbsp;(169)</option><option value='https://glidemagazine.com/date/2016/12/'> December 2016 &nbsp;(129)</option><option value='https://glidemagazine.com/date/2016/11/'> November 2016 &nbsp;(157)</option><option value='https://glidemagazine.com/date/2016/10/'> October 2016 &nbsp;(188)</option><option value='https://glidemagazine.com/date/2016/09/'> September 2016 &nbsp;(186)</option><option value='https://glidemagazine.com/date/2016/08/'> August 2016 &nbsp;(172)</option><option value='https://glidemagazine.com/date/2016/07/'> July 2016 &nbsp;(161)</option><option value='https://glidemagazine.com/date/2016/06/'> June 2016 &nbsp;(161)</option><option value='https://glidemagazine.com/date/2016/05/'> May 2016 &nbsp;(153)</option><option value='https://glidemagazine.com/date/2016/04/'> April 2016 &nbsp;(164)</option><option value='https://glidemagazine.com/date/2016/03/'> March 2016 &nbsp;(165)</option><option value='https://glidemagazine.com/date/2016/02/'> February 2016 &nbsp;(154)</option><option value='https://glidemagazine.com/date/2016/01/'> January 2016 &nbsp;(140)</option><option value='https://glidemagazine.com/date/2015/12/'> December 2015 &nbsp;(120)</option><option value='https://glidemagazine.com/date/2015/11/'> November 2015 &nbsp;(148)</option><option value='https://glidemagazine.com/date/2015/10/'> October 2015 &nbsp;(171)</option><option value='https://glidemagazine.com/date/2015/09/'> September 2015 &nbsp;(156)</option><option value='https://glidemagazine.com/date/2015/08/'> August 2015 &nbsp;(161)</option><option value='https://glidemagazine.com/date/2015/07/'> July 2015 &nbsp;(183)</option><option value='https://glidemagazine.com/date/2015/06/'> June 2015 &nbsp;(168)</option><option value='https://glidemagazine.com/date/2015/05/'> May 2015 &nbsp;(163)</option><option value='https://glidemagazine.com/date/2015/04/'> April 2015 &nbsp;(162)</option><option value='https://glidemagazine.com/date/2015/03/'> March 2015 &nbsp;(137)</option><option value='https://glidemagazine.com/date/2015/02/'> February 2015 &nbsp;(142)</option><option value='https://glidemagazine.com/date/2015/01/'> January 2015 &nbsp;(135)</option><option value='https://glidemagazine.com/date/2014/12/'> December 2014 &nbsp;(96)</option><option value='https://glidemagazine.com/date/2014/11/'> November 2014 &nbsp;(102)</option><option value='https://glidemagazine.com/date/2014/10/'> October 2014 &nbsp;(152)</option><option value='https://glidemagazine.com/date/2014/09/'> September 2014 &nbsp;(119)</option><option value='https://glidemagazine.com/date/2014/08/'> August 2014 &nbsp;(118)</option><option value='https://glidemagazine.com/date/2014/07/'> July 2014 &nbsp;(117)</option><option value='https://glidemagazine.com/date/2014/06/'> June 2014 &nbsp;(149)</option><option value='https://glidemagazine.com/date/2014/05/'> May 2014 &nbsp;(126)</option><option value='https://glidemagazine.com/date/2014/04/'> April 2014 &nbsp;(113)</option><option value='https://glidemagazine.com/date/2014/03/'> March 2014 &nbsp;(102)</option><option value='https://glidemagazine.com/date/2014/02/'> February 2014 &nbsp;(92)</option><option value='https://glidemagazine.com/date/2014/01/'> January 2014 &nbsp;(112)</option><option value='https://glidemagazine.com/date/2013/12/'> December 2013 &nbsp;(103)</option><option value='https://glidemagazine.com/date/2013/11/'> November 2013 &nbsp;(122)</option><option value='https://glidemagazine.com/date/2013/10/'> October 2013 &nbsp;(162)</option><option value='https://glidemagazine.com/date/2013/09/'> September 2013 &nbsp;(162)</option><option value='https://glidemagazine.com/date/2013/08/'> August 2013 &nbsp;(141)</option><option value='https://glidemagazine.com/date/2013/07/'> July 2013 &nbsp;(180)</option><option value='https://glidemagazine.com/date/2013/06/'> June 2013 &nbsp;(221)</option><option value='https://glidemagazine.com/date/2013/05/'> May 2013 &nbsp;(256)</option><option value='https://glidemagazine.com/date/2013/04/'> April 2013 &nbsp;(310)</option><option value='https://glidemagazine.com/date/2013/03/'> March 2013 &nbsp;(305)</option><option value='https://glidemagazine.com/date/2013/02/'> February 2013 &nbsp;(270)</option><option value='https://glidemagazine.com/date/2013/01/'> January 2013 &nbsp;(268)</option><option value='https://glidemagazine.com/date/2012/12/'> December 2012 &nbsp;(255)</option><option value='https://glidemagazine.com/date/2012/11/'> November 2012 &nbsp;(228)</option><option value='https://glidemagazine.com/date/2012/10/'> October 2012 &nbsp;(288)</option><option value='https://glidemagazine.com/date/2012/09/'> September 2012 &nbsp;(82)</option><option value='https://glidemagazine.com/date/2012/08/'> August 2012 &nbsp;(163)</option><option value='https://glidemagazine.com/date/2012/07/'> July 2012 &nbsp;(253)</option><option value='https://glidemagazine.com/date/2012/06/'> June 2012 &nbsp;(286)</option><option value='https://glidemagazine.com/date/2012/05/'> May 2012 &nbsp;(267)</option><option value='https://glidemagazine.com/date/2012/04/'> April 2012 &nbsp;(266)</option><option value='https://glidemagazine.com/date/2012/03/'> March 2012 &nbsp;(293)</option><option value='https://glidemagazine.com/date/2012/02/'> February 2012 &nbsp;(256)</option><option value='https://glidemagazine.com/date/2012/01/'> January 2012 &nbsp;(269)</option><option value='https://glidemagazine.com/date/2011/12/'> December 2011 &nbsp;(240)</option><option value='https://glidemagazine.com/date/2011/11/'> November 2011 &nbsp;(239)</option><option value='https://glidemagazine.com/date/2011/10/'> October 2011 &nbsp;(260)</option><option value='https://glidemagazine.com/date/2011/09/'> September 2011 &nbsp;(134)</option><option value='https://glidemagazine.com/date/2011/08/'> August 2011 &nbsp;(276)</option><option value='https://glidemagazine.com/date/2011/07/'> July 2011 &nbsp;(237)</option><option value='https://glidemagazine.com/date/2011/06/'> June 2011 &nbsp;(269)</option><option value='https://glidemagazine.com/date/2011/05/'> May 2011 &nbsp;(250)</option><option value='https://glidemagazine.com/date/2011/04/'> April 2011 &nbsp;(241)</option><option value='https://glidemagazine.com/date/2011/03/'> March 2011 &nbsp;(295)</option><option value='https://glidemagazine.com/date/2011/02/'> February 2011 &nbsp;(235)</option><option value='https://glidemagazine.com/date/2011/01/'> January 2011 &nbsp;(261)</option><option value='https://glidemagazine.com/date/2010/12/'> December 2010 &nbsp;(239)</option><option value='https://glidemagazine.com/date/2010/11/'> November 2010 &nbsp;(239)</option><option value='https://glidemagazine.com/date/2010/10/'> October 2010 &nbsp;(268)</option><option value='https://glidemagazine.com/date/2010/09/'> September 2010 &nbsp;(245)</option><option value='https://glidemagazine.com/date/2010/08/'> August 2010 &nbsp;(266)</option><option value='https://glidemagazine.com/date/2010/07/'> July 2010 &nbsp;(268)</option><option value='https://glidemagazine.com/date/2010/06/'> June 2010 &nbsp;(298)</option><option value='https://glidemagazine.com/date/2010/05/'> May 2010 &nbsp;(253)</option><option value='https://glidemagazine.com/date/2010/04/'> April 2010 &nbsp;(251)</option><option value='https://glidemagazine.com/date/2010/03/'> March 2010 &nbsp;(284)</option><option value='https://glidemagazine.com/date/2010/02/'> February 2010 &nbsp;(238)</option><option value='https://glidemagazine.com/date/2010/01/'> January 2010 &nbsp;(227)</option><option value='https://glidemagazine.com/date/2009/12/'> December 2009 &nbsp;(202)</option><option value='https://glidemagazine.com/date/2009/11/'> November 2009 &nbsp;(228)</option><option value='https://glidemagazine.com/date/2009/10/'> October 2009 &nbsp;(254)</option><option value='https://glidemagazine.com/date/2009/09/'> September 2009 &nbsp;(250)</option><option value='https://glidemagazine.com/date/2009/08/'> August 2009 &nbsp;(218)</option><option value='https://glidemagazine.com/date/2009/07/'> July 2009 &nbsp;(265)</option><option value='https://glidemagazine.com/date/2009/06/'> June 2009 &nbsp;(255)</option><option value='https://glidemagazine.com/date/2009/05/'> May 2009 &nbsp;(225)</option><option value='https://glidemagazine.com/date/2009/04/'> April 2009 &nbsp;(241)</option><option value='https://glidemagazine.com/date/2009/03/'> March 2009 &nbsp;(283)</option><option value='https://glidemagazine.com/date/2009/02/'> February 2009 &nbsp;(256)</option><option value='https://glidemagazine.com/date/2009/01/'> January 2009 &nbsp;(272)</option><option value='https://glidemagazine.com/date/2008/12/'> December 2008 &nbsp;(202)</option><option value='https://glidemagazine.com/date/2008/11/'> November 2008 &nbsp;(181)</option><option value='https://glidemagazine.com/date/2008/10/'> October 2008 &nbsp;(232)</option><option value='https://glidemagazine.com/date/2008/09/'> September 2008 &nbsp;(254)</option><option value='https://glidemagazine.com/date/2008/08/'> August 2008 &nbsp;(239)</option><option value='https://glidemagazine.com/date/2008/07/'> July 2008 &nbsp;(242)</option><option value='https://glidemagazine.com/date/2008/06/'> June 2008 &nbsp;(225)</option><option value='https://glidemagazine.com/date/2008/05/'> May 2008 &nbsp;(225)</option><option value='https://glidemagazine.com/date/2008/04/'> April 2008 &nbsp;(255)</option><option value='https://glidemagazine.com/date/2008/03/'> March 2008 &nbsp;(239)</option><option value='https://glidemagazine.com/date/2008/02/'> February 2008 &nbsp;(231)</option><option value='https://glidemagazine.com/date/2008/01/'> January 2008 &nbsp;(231)</option><option value='https://glidemagazine.com/date/2007/12/'> December 2007 &nbsp;(197)</option><option value='https://glidemagazine.com/date/2007/11/'> November 2007 &nbsp;(221)</option><option value='https://glidemagazine.com/date/2007/10/'> October 2007 &nbsp;(220)</option><option value='https://glidemagazine.com/date/2007/09/'> September 2007 &nbsp;(197)</option><option value='https://glidemagazine.com/date/2007/08/'> August 2007 &nbsp;(238)</option><option value='https://glidemagazine.com/date/2007/07/'> July 2007 &nbsp;(162)</option><option value='https://glidemagazine.com/date/2007/06/'> June 2007 &nbsp;(186)</option><option value='https://glidemagazine.com/date/2007/05/'> May 2007 &nbsp;(186)</option><option value='https://glidemagazine.com/date/2007/04/'> April 2007 &nbsp;(202)</option><option value='https://glidemagazine.com/date/2007/03/'> March 2007 &nbsp;(173)</option><option value='https://glidemagazine.com/date/2007/02/'> February 2007 &nbsp;(146)</option><option value='https://glidemagazine.com/date/2007/01/'> January 2007 &nbsp;(170)</option><option value='https://glidemagazine.com/date/2006/12/'> December 2006 &nbsp;(148)</option><option value='https://glidemagazine.com/date/2006/11/'> November 2006 &nbsp;(146)</option><option value='https://glidemagazine.com/date/2006/10/'> October 2006 &nbsp;(112)</option><option value='https://glidemagazine.com/date/2006/09/'> September 2006 &nbsp;(91)</option><option value='https://glidemagazine.com/date/2006/08/'> August 2006 &nbsp;(112)</option><option value='https://glidemagazine.com/date/2006/07/'> July 2006 &nbsp;(97)</option><option value='https://glidemagazine.com/date/2006/06/'> June 2006 &nbsp;(128)</option><option value='https://glidemagazine.com/date/2006/05/'> May 2006 &nbsp;(127)</option><option value='https://glidemagazine.com/date/2006/04/'> April 2006 &nbsp;(128)</option><option value='https://glidemagazine.com/date/2006/03/'> March 2006 &nbsp;(126)</option><option value='https://glidemagazine.com/date/2006/02/'> February 2006 &nbsp;(108)</option><option value='https://glidemagazine.com/date/2006/01/'> January 2006 &nbsp;(117)</option><option value='https://glidemagazine.com/date/2005/12/'> December 2005 &nbsp;(116)</option><option value='https://glidemagazine.com/date/2005/11/'> November 2005 &nbsp;(125)</option><option value='https://glidemagazine.com/date/2005/10/'> October 2005 &nbsp;(148)</option><option value='https://glidemagazine.com/date/2005/09/'> September 2005 &nbsp;(126)</option><option value='https://glidemagazine.com/date/2005/08/'> August 2005 &nbsp;(154)</option><option value='https://glidemagazine.com/date/2005/07/'> July 2005 &nbsp;(126)</option><option value='https://glidemagazine.com/date/2005/06/'> June 2005 &nbsp;(150)</option><option value='https://glidemagazine.com/date/2005/05/'> May 2005 &nbsp;(129)</option><option value='https://glidemagazine.com/date/2005/04/'> April 2005 &nbsp;(105)</option><option value='https://glidemagazine.com/date/2005/03/'> March 2005 &nbsp;(146)</option><option value='https://glidemagazine.com/date/2005/02/'> February 2005 &nbsp;(114)</option><option value='https://glidemagazine.com/date/2005/01/'> January 2005 &nbsp;(106)</option><option value='https://glidemagazine.com/date/2004/12/'> December 2004 &nbsp;(121)</option><option value='https://glidemagazine.com/date/2004/11/'> November 2004 &nbsp;(117)</option><option value='https://glidemagazine.com/date/2004/10/'> October 2004 &nbsp;(108)</option><option value='https://glidemagazine.com/date/2004/09/'> September 2004 &nbsp;(115)</option><option value='https://glidemagazine.com/date/2004/08/'> August 2004 &nbsp;(130)</option><option value='https://glidemagazine.com/date/2004/07/'> July 2004 &nbsp;(119)</option><option value='https://glidemagazine.com/date/2004/06/'> June 2004 &nbsp;(114)</option><option value='https://glidemagazine.com/date/2004/05/'> May 2004 &nbsp;(115)</option><option value='https://glidemagazine.com/date/2004/04/'> April 2004 &nbsp;(119)</option><option value='https://glidemagazine.com/date/2004/03/'> March 2004 &nbsp;(98)</option><option value='https://glidemagazine.com/date/2004/02/'> February 2004 &nbsp;(77)</option><option value='https://glidemagazine.com/date/2004/01/'> January 2004 &nbsp;(99)</option><option value='https://glidemagazine.com/date/2003/12/'> December 2003 &nbsp;(63)</option><option value='https://glidemagazine.com/date/2003/11/'> November 2003 &nbsp;(52)</option><option value='https://glidemagazine.com/date/2003/10/'> October 2003 &nbsp;(56)</option><option value='https://glidemagazine.com/date/2003/09/'> September 2003 &nbsp;(69)</option><option value='https://glidemagazine.com/date/2003/08/'> August 2003 &nbsp;(58)</option><option value='https://glidemagazine.com/date/2003/07/'> July 2003 &nbsp;(66)</option><option value='https://glidemagazine.com/date/2003/06/'> June 2003 &nbsp;(104)</option><option value='https://glidemagazine.com/date/2003/05/'> May 2003 &nbsp;(64)</option><option value='https://glidemagazine.com/date/2003/04/'> April 2003 &nbsp;(72)</option><option value='https://glidemagazine.com/date/2003/03/'> March 2003 &nbsp;(74)</option><option value='https://glidemagazine.com/date/2003/02/'> February 2003 &nbsp;(46)</option><option value='https://glidemagazine.com/date/2003/01/'> January 2003 &nbsp;(1)</option> </select> <script type="text/javascript">(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();</script> </div></div><div class="clear"></div><div id="footer"><div class="four columns"></div><div class="four columns"></div><div class="four columns"></div><div class="four columns"></div><div class="clear"></div></div><div id="copyright"><div class="copyright_left"> Copyright &copy; 2021 <a href="https://glidemagazine.com">Glide Publishing LLC</a> &nbsp;All Rights Reserved</a></div><div class="copyright_right"></div><div class="clear"></div> <br /><center><div id="advert-footer"><div id="mmt-e95f866f-6e6d-4e69-83f9-7b68ac1105f2"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["e95f866f-6e6d-4e69-83f9-7b68ac1105f2"]); })</script> </div></center></div></div><div style="display:none"><div class="grofile-hash-map-b62389276a764499b4f16ac77e638ab2"></div></div> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script> <script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js'></script> <script type='text/javascript'>var WPGroHo = {"my_hash":""};</script> <script type='text/javascript' src='https://stats.wp.com/e-202104.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.6.1',blog:'147281625',post:'253000',tz:'-5',srv:'glidemagazine.com'} ]);
	_stq.push([ 'clickTrackerInit', '147281625', '253000' ]);</script> <script type="text/javascript">jQuery(document).ready(function($) {
	var theme_id = 'SmartPress';
		
	// Save
	$('#save_change').click(function(){
		var skin = $("#predefined_skins input").val();
		var primary_color = $("#primary_color input").val();
		var link_color = $("#link_color input").val();
		var custom_bg_color = $("#custom_bg_color input").val();
		var pattent = $("#custom_bg_image input").val();
		var main_text_color = $("#main_text_color input").val();
		
		$.cookie(theme_id+'-skin', skin, { path: '/' });
		$.cookie(theme_id+'-primary_color', primary_color, { path: '/' });
		$.cookie(theme_id+'-link_color', link_color, { path: '/' });
		$.cookie(theme_id+'-custom_bg_color', custom_bg_color, { path: '/' });
		$.cookie(theme_id+'-pattent', pattent, { path: '/' });
		$.cookie(theme_id+'-main_text_color', main_text_color, { path: '/' });

		setTimeout('location.reload(true);', 1200);
		return false;
	});		
	
	// Reset
	$('#reset_change').click(function(){
		$.cookie(theme_id+'-skin', null, { path: '/' });
		$.cookie(theme_id+'-primary_color', null, { path: '/' });
		$.cookie(theme_id+'-link_color', null, { path: '/' });
		$.cookie(theme_id+'-custom_bg_color', null, { path: '/' });
		$.cookie(theme_id+'-pattent', null, { path: '/' });
		$.cookie(theme_id+'-main_text_color', null, { path: '/' });
		
		setTimeout('location.reload(true);', 1200);
		return false;
	});										 

});</script> <div id="izi-control-panel"> <a id="izi-control-close" class="control-open" href="#"></a><div class="padd"><div class="input" id="predefined_skins"><h3>Example Skins</h3> <img class="tooltip selected" src="https://glidemagazine.com/wp-content/themes/SmartPress/admin/images/skin_thumb/dark_red.png" data-pr_color='cc3300' data-link_color='cc3300' data-bg_color='222222' data-pattern='pattern-1' alt='dark_red' title='Dark / Red' /> <img class="tooltip" src="https://glidemagazine.com/wp-content/themes/SmartPress/admin/images/skin_thumb/dark_navi.png" data-pr_color='336875' data-link_color='336875' data-bg_color='222222' data-pattern='pattern-2' alt='dark_navi' title="Dark / Navi"/> <img class="tooltip" src="https://glidemagazine.com/wp-content/themes/SmartPress/admin/images/skin_thumb/dark_brown.png" data-pr_color='66372a' data-link_color='66372a' data-bg_color='222222' data-pattern='pattern-3' alt='dark_brown' title="Dark / Brown"/> <img class="tooltip" src="https://glidemagazine.com/wp-content/themes/SmartPress/admin/images/skin_thumb/light_red.png" data-pr_color='cc3300' data-link_color='cc3300' data-bg_color='d5d5d5' data-pattern='pattern-4' alt='light_red' title='Light / Red'  /> <img class="tooltip" src="https://glidemagazine.com/wp-content/themes/SmartPress/admin/images/skin_thumb/light_navi.png" data-pr_color='336875' data-link_color='336875' data-bg_color='d5d5d5' data-pattern='pattern-5' alt='light_navi' title="Light / Navi"/> <img class="tooltip" src="https://glidemagazine.com/wp-content/themes/SmartPress/admin/images/skin_thumb/light_brown.png" data-pr_color='66372a' data-link_color='66372a' data-bg_color='d5d5d5' data-pattern='pattern-6' alt='light_brown' title="Light / Brown"/> <input type="hidden" value='dark_red' name='skin' /></div><div class='input'><h3>Primary Color</h3><div id='primary_color' class='colorpicker_wrapper'> <input type='text' value='858585' name='primary_color' /><div class="colorSelector"><div style='background-color: #858585;'></div></div></div></div><div class='input'><h3>Link Color</h3><div id='link_color' class='colorpicker_wrapper'> <input type='text' value='800000' name='link_color' /><div class="colorSelector"><div style='background-color: #800000;'></div></div></div></div><div class='input'><h3>Background Color</h3><div id='custom_bg_color' class='colorpicker_wrapper'> <input type='text' value='222222' name='custom_bg_color' /><div class="colorSelector"><div style='background-color: #222222;'></div></div></div></div><div class='input'><h3>Background Patterns</h3><div id='custom_bg_image'> <img class="tooltip selected"  src='https://glidemagazine.com/wp-content/themes/SmartPress/admin/_switcher/images/_blank.gif' width="30" height="30" style="background: #eee url(https://glidemagazine.com/wp-content/themes/SmartPress/images/patterns/pattern-1.png)" alt='pattern-1' /> <img class="tooltip"  src='https://glidemagazine.com/wp-content/themes/SmartPress/admin/_switcher/images/_blank.gif' width="30" height="30" style="background: #eee url(https://glidemagazine.com/wp-content/themes/SmartPress/images/patterns/pattern-2.png)" alt='pattern-2' /> <img class="tooltip" src='https://glidemagazine.com/wp-content/themes/SmartPress/admin/_switcher/images/_blank.gif' width="30" height="30" style="background: #eee url(https://glidemagazine.com/wp-content/themes/SmartPress/images/patterns/pattern-3.png)" alt='pattern-3' /> <img class="tooltip"  src='https://glidemagazine.com/wp-content/themes/SmartPress/admin/_switcher/images/_blank.gif' width="30" height="30" style="background: #eee url(https://glidemagazine.com/wp-content/themes/SmartPress/images/patterns/pattern-4.png)" alt='pattern-4' /> <img class="tooltip" src='https://glidemagazine.com/wp-content/themes/SmartPress/admin/_switcher/images/_blank.gif' width="30" height="30" style="background: #eee url(https://glidemagazine.com/wp-content/themes/SmartPress/images/patterns/pattern-5.png)" alt='pattern-5' /> <img class="tooltip" src='https://glidemagazine.com/wp-content/themes/SmartPress/admin/_switcher/images/_blank.gif' width="30" height="30" style="background: #eee url(https://glidemagazine.com/wp-content/themes/SmartPress/images/patterns/pattern-6.png)" alt='pattern-6' /> <input type="hidden" name="custom_bg_image" value="pattern-1" /></div></div><div class='input'><h3>Main text color</h3><div id='main_text_color' class='colorpicker_wrapper'> <input type='text' value='' name='main_text_color' /><div class="colorSelector"><div style='background-color: #;'></div></div></div></div><div> <input type="button" value="Save" id="save_change" name="save_change" /> <input id="reset_change" type="button" value="Reset" name="reset_change" /></div></div></div> <script type="text/javascript" defer src="https://glidemagazine.com/wp-content/cache/autoptimize/js/autoptimize_b72e4faa86f81fb23ce47d3609335f10.js"></script><script async type="text/javascript" src="/_Incapsula_Resource?SWJIYLWA=719d34d31c8e3a6e6fffd425f7e032f3&ns=2&cb=1047915023"></script>
</body></html>